Star

Setup

Download or Link

If you use NPM, npm install d2b. Otherwise, download the latest release.

Include Dependencies

D2B requires d3.js >= 4.0.0.

If you would like to use the built in vue.js components. Be sure to include vue.js >= 2.0.0.

Basics

Generating a Chart

D2B has several different types of charts, each of them use a similar API. Here is an example of a line-chart d2b.chartAxis.


    JS
    HTML
    CSS

Updating a Chart

Each chart can be updated instantly to reflect a new set of bound d3 datum(). Or it can be transitioned to the new set like in the pie chart example below.


    JS
    HTML
    CSS